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Introduction
Welcome to Excel 2: Analysis! This course will build upon the basic skills you learned in the Excel 1 class. After this
class, you will be able to utilize Excel's advanced analysis tools to summarize data, solve complex equations and
perform "What-If" analyses on the data.

About this Class

Excel 2: Analysis is one of three intermediate Excel classes offered by Software Training for Students. These three
classes (Functions, Data Visualization, and Analysis) are designed so you can take them independently and in any
order. After this class, you will be able to utilize powerful features of Excel which allow you to analyze data faster and
easier.

As of 2016, Microsoft Office has combined its PC and Mac versions to provide the same experience to all users.
However, one major difference remains, that it, the use of the Control and Command keys on Windows and Mac
respectively for keyboard shortcuts. These keys essentially perform the same function and are used in conjunction
with other keys to perform various tasks quicker. Your instructor will mention these interchangeably.

Required Skills

You should have a basic knowledge of the Windows environment, and have taken Excel 1, or have equivalent
experience.

Key background skills needed include familiarity with the following:

Common terminology: rows, columns and cells

Entering and editing data

Basic formulas: addition, subtraction, product, division, etc.

Built-in functions: sum, average, etc.

Other Requirements

In addition to this manual, you will need to download the class files for the course and have access to a computer
with Microsoft Office 2016. The class files can be downloaded at the STS website or will be provided by your
instructor.



If you are working on an older version of Office, some features may be located in different locations or, on rare
occasions, may be unavailable altogether. In such cases, setting up an Ask-a-Trainer appointment with an STS trainer
via the STS website would allow you to work through your specific questions. Otherwise, Microsoft Office is also
available on most campus computer labs. Office 2016 can also be acquired free of cost as a student here:
it.wisc.edu/services/office-365/

https://it.wisc.edu/services/office-365/


To begin, find the Excel-2-Analysis-2016.xlsx  file from the downloaded Class Files and open it. Examine the various
exercises in the worksheets.

Input Tables
Creating tables in Excel can make managing and analyzing hypothetical data very easy. In this section, we will use a
table with two inputs to analyze how the outcomes of a final exam score and project score will affect our overall
semester grade. In other words, we can create a table that contains all possible outcomes for our exam and project
grades and have Excel calculate our final semester grade based on that table.

"What-If" Data Table

Navigate to the Two Input worksheet. This section explains how to use “What-If” Data Tables, which is an available
tool through “What-If” Analysis.

In this example, it is the end of the semester. For this class, we have already completed six homework assignments
and three exams whose grades are already specified in the worksheet. The only items left to be completed and graded
are the final exam and a final project. We want to know what our final grade would be depending on what grade we
receive on these two remaining assignments.

We still have not completed our project or final exam, but we need some values as starting points to calculate our
hypothetical final grade.

In cells F5 and G5, enter a value of 80% for the Project grade and 85% for the Final Exam grade.

Now we must write an equation to calculate our final grade as shown below. Here, we sum the products of the
different grade components with their respective weights.

In cell K8, Insert the formula =0.1*B11+0.4*E8+0.2*F5+0.3*G5.
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Press Enter

Again, remember that the project and final exam grades are just guesses so that we can write a complete formula for
our semester grade calculation. Now that we have done that, we can fill in the "What-if" table.

Filling a Series of Data
This exercise explains how to fill in the data table with possible values for “What-If” analysis. This “What-If” table has
an empty row along the top to fill in with hypothetical project grades and an empty column on the left to fill in with
hypothetical exam grades. Let’s use a few Auto Fill features to put in the grades.

In cell G20, type 0.

In cell H20, type 10.

These are both automatically changed into percentages due to the number formatting of the cells.

Select cells G20 and H20 and Autofill the selection until cell Q20. This completes the series from 0% to 100% in
increments of 10%.

In cell F21, type 0.

Select cells F21:F41.
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Series... dialog box

The Series dialog box let's us
instruct Excel how to fill in the
cells we had selected based on the
given starting value.

We have a column selected so we
leave "Series in Columns." We also
want our hypothetical grades to be
evenly spaced we leave Type as
"Linear." Stop value can be ignored
because we want the entire range
we selected to be filled. The Step
value increases each consecutive
cell by that specified amount until
all the selected cells are filled.

Navigate to the Home tab and fine the Fill button. From the drop-down
menu, select Series....

Specify a Step value of 0.05, leaving all the other options as is, and click OK.

Excel automatically completes the columns by incrementing each cell by 5% to the end.
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Performing a What-If Analysis
The data table is almost ready perform the “What-If Analysis.” This allows us to iteratively solve a formula based on
parameters supplied to it by a table. Our semester grade calculation is a perfect use for it. In order for a ‘What-If’
table to work properly, we must specify a specific equation that we want to alter the values of. For this example, we
will use the Semester Grade formula in K8 and use “What-If” Analysis to see how our project and final exam grades
will affect our semester grade.

In cell F20, type =K8 and press Enter.

Select cells F20:Q41 (the entire table).

Switch to the Data tab in the ribbon and find What-If Analysis under the Forecast panel.
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Select Data Table from the What-If Analysis drop-down menu.

In Row input cell, we want to enter the project grade, because this is the first variable we want to vary in our
semester grade equation.

Click in the Row input cell field and then click cell F5 (project) in the workspace.

In Column input cell, we want to enter the Final Exam grade, because this is the second variable we want to
vary in our semester grade equation.

Click in the Column input cell field and then click in cell G5 (final exam) in the workspace.

Click OK.

The table is now filled out with many possible values for our final semester grade. We can double check our results by
finding our original guess values for the project (80%) and final exam (85%) and see if they match our original
semester grade (85.95%).
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You have now successfully completed a two input table!

Subtotal
Switch to the SUBTOTAL worksheet. This worksheet may be familiar to you from our Excel 1 course. It contains the
inventory of a sporting goods store along with information on the sales for each item. Note the small arrow in each
column header. Remember that clicking on these arrows will open a filter menu for that header. This worksheet also
has the freeze panes option enabled to allow us to see our headers while we are looking at the summary rows at the
bottom of the sheet.

Let’s say we are interested in knowing about sales figures for our camping items. We can use the filter menu to sort
category by camping and then try creating functions that summarize the data for us.

Click the small arrow next to the column title Category for the drop-down menu.1



Filter the Category column to display only the Camping items and click OK.

In cell C72, type =MIN(.

Select the range of data by Clicking in cell C19 and Dragging to C52.

Type a closing parenthesis ) and press Enter. A minimum value of $1.99 is returned even though the lowest
item cost for the items displayed is $11.99 (Lantern). By clicking in cell C72, you can see the function reads
=MIN(C19:C52).

Update cell C72 to read =MIN(C19,C21,C32,C36,C42,C45,C52). The correct minimum of $11.99 is found so
we know that this function works.
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We get $1.99 initially because when we made our selection, even though it appeared like we only selected the item
cost values the camping items, we also selected values that are currently hidden. It found the minimum for all the
cells between C19 and C52 while the camping items are only located in rows 19, 21, 32, 36, 42, 45, and 52.

However, if we wanted to examine the sales for a different category by changing the filter, this function would not
update and instead it would still report the camping category information. We could update this formula every time
we changed the filter, but this would be quite the hassle.

Instead, we can use a different function to do the work for us such as the SUBTOTAL function. The SUBTOTAL
function is convenient because it automatically updates its calculations to only include the currently displayed data
based on the filter. We will now use the SUBTOTAL function to perform AVERAGE, MAX, and MIN operations, in
addition to the SUM operation.

Delete the formula in cell C72.

Click the small drop down arrow next to the column title Category.

Click on the box labeled Select All. This will remove any filters previously applied to the column Category.

In cell C72, type =SUBTOTAL(.

Complete the formula to read =SUBTOTAL(5,C3:C67).

Complete all the other SUBTOTAL functions for the rest of the filtered summary data by using function
numbers the respective function numbers.
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SUBTOTAL arguments

The SUBTOTAL function uses
function numbers for arguments
that indicate what type of
calculation Excel should perform.
Some common ones from the
drop-down list are:

1 - Average

2 - Count

4 - Max

5 - Min

9 - Sum

Change the Category filter to Apparel and Check to see that the
functions update accordingly.

By using the SUBTOTAL function, we are able to maximize the potential of the filter feature in Excel. For this reason,
the filter option is often used more than the sort command when looking at snapshots of a larger portion of data. The
sort command is more often used to permanently reorder your data.

Goal Seek
Excel has tools available that can be used to solve both simple and complex mathematical equations. We will look at
one of these tools now called Goal Seek. Excel’s Goal Seek feature allows you to alter the input values in a formula in
order to find out what the results will be. When Goal Seek is used properly, we can use it to solve algebraic equations.

Switch to the Goal Seek worksheet for this section.

The Goal Seek function has three parameters:

Set cell: This is the cell whose value is changed to the goal value defined in the To value form.
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To value: The goal value is specified here.

By changing cell: This cell's value is used as a variable which is changed so as to satisfy the goal value in the
Set cell.

Calculation of Semester Grades

For our first example, we will go back to the semester grade problem and calculate the exact score we need on the
test to receive an A (90%) for the semester using Goal Seek. Before we begin, navigate to cell G10 to view the formula
we will be working with. It should look familiar, as it is similar to the semester grade calculation that we have used for
input tables. The following exercise explains how Goal Seek can be used to calculate theoretical results for our data.

Click in cell G10, the semester grade. This is the cell we will be changing.

From the Data tab in the ribbon, find What-If Analysis under the Forecast panel.

Select Goal Seek from the What-If Analysis drop-down menu.

In the Set cell form, input cell $G$10.

In the To value form, type 0.90.

In the By changing cell form, input cell $H$4.

Here we set the semester grade to the desired target of 90% by changing the final exam score.

Click OK twice
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Payment function

We have used the Excel function
PMT to calculate each monthly
payment for the loan. The payment
function works as follows:

=PMT(interest rate on loan, total
amount of payments to make on
loan, initial loaned amount)

We now know that we need to score a 91.57% or better on the final exam in cell H4 to receive an A for the semester.

Calculation of Loan Payments

This exercise explains how to use Goal Seek to evaluate a loan payment. Here, we will work with a loan that we have
taken out. We have taken out a $100,000 loan at a yearly interest rate of 7% that we intend to pay off in four years (48
months). Right now, our current monthly payment is $2394.62. However, we can only afford to pay $2000 a month on
our loan and want to figure out how long it will take us to pay it off.

Select cell B21 and click on Goal Seek as done previously.

In the Set cell form, input cell $B$21.

In the To value form, type 2000.

In the By changing cell form, input cell $B$19.

Here, we are changing our monthly payment to the desired payment we want to make by changing the
amount of time it will take us to pay off the loan.

Click OK twice

We can see that it will take us about 59.3 months to pay off our loan with $2000/month payments. Since we don’t
make a payment at 0.3 months, we will round it up to 60 months which comes to 5 years. Not bad!

A Physics Problem

For our last “What-If Analysis” example we will solve a physics problem. We want to figure out how far we can throw a
ball before it hits the ground. We’ll say we can throw at about 15 m/sec (roughly 34 mph). Click on cells B30 and B31
to see how we calculated the horizontal and vertical velocity of the ball. Don’t worry about getting too absorbed in
the physics, but notice the use of the RADIANS function that converted our measurement of the angle we can throw
at from degrees to radians. To solve this problem, we should set our vertical velocity to the negative of its initial value
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by changing the amount of time the ball has been in the air. When our vertical velocity is at the opposite of this value,
we know that the ball has landed.

Select cell B31. This corresponds to our vertical velocity.

Find Goal Seek once again and click on it.

In the Set cell form, input cell $B$31.

In the To value form, type -11.49.

In the Be changing cell form, input cell $B$28.

Here, we are setting the vertical velocity to its final value when the ball hits the ground by changing the time
it takes for the ball to hit the ground. We can use this information to see how far we can throw the ball.

Click OK twice

We can see now that it will take the ball 2.34 seconds to hit the ground, and we can throw the ball 23 meters (about 74
feet).

Goal Seek Review

Here are few things to remember about Goal Seek before we move on:

Since Goal Seek is used to solve equations, always make sure the Set cell has an equation or formula in it, i.e.,
something that will vary based on other numbers.

To value is the value you want, i.e., your goal.

By changing cell is a variable that changes in order to enable the previous two arguments.

However, Goal Seek is limited in its equation solving abilities as it can only solve one equation, and you cannot add
any constraints or limits on your solution. Our next topic, the Solver, will allow you to solve multiple equations with
multiple constraints.
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Solver
This section explains how to use Solver to solve multiple equations at the same time. Goal Seek is an excellent
resource for single variable solutions and simple formulas. But when multiple variables are introduced, Goal Seek is
not as an effective of a tool as another built-in program called Solver. Solver is part of an Add-In to Excel, meaning
that we need to check and make sure we have that Add-In installed.

Before we learn about Add-ins in the following section, switch to the Solver worksheet in your Excel workbook.

Add-Ins

Add-Ins are small programs that add additional functionality to Excel. These may be created by Microsoft or a third-
party in order to provide tools that more proficient users of Excel may require. We first need to check and make sure
the add-in is active on your computer.

Add-Ins are small programs that add additional functionality to Excel. These may be created by Microsoft or a third-
party in order to provide tools that more proficient users of Excel may require. We first need to check and make sure
the add-in is active on your computer.

Switch to the File tab and click Options.

Navigate to the Add-ins options

Find the Manage drop-down menu, select Excel Add-ins and click Go....
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From the list of available add-ins, check the Analysis ToolPak and Solver Add-In, and click OK.

These Add-ins can now be found in the Data tab under the Analyze section. The process of loading the Add-ins into
Excel may be slow so please be patient. If you are prompted to install the Add-ins, go ahead and click Yes to install
them.

One-Variable Math Example

In Example 1, we will solve the equation "y=x-5" for x. This is very similar to how we used Goal Seek to solve
equations, except for this example we will use the Solver tool.

Like Goal Seek, Solver needs both a guess value and a formula to evaluate.

In cell B5, type a guess value for x, such as 3.

In cell B6, type the formula =B5-5.
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We will now use Solver to find the value of x that yields zero as the y value.

Navigate to the Data tab.

In the Analyze section, select Solver.

Click Reset All to remove any previous input.

Input the following into the forms:

Set Objective: $B$6
To: Value Of: 0

By Changing Variable Cells: $B$5
Solving Method: Simplex LP

By setting the value of B6 equal to zero and changing cell B5 (or x guess) we will gain our solution for x when y
= 0.

Click Solve
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Another dialogue box prompts to keep or discard the solution. Click OK too keep the solution if it seems
logical.

We have now solved y = x – 5 for y = 0 using both Goal Seek and Solver. For this simple example, Goal Seek is a more
efficient option but both get the same solution. Let’s look at a multi-variable set of equations in order to see the real
power of Solver.

Multi-Variable Example

Example 2 shows two equations, whose lines intersect at a given point. We are going to use the values of x and y to
find the point where these lines intersect.

Let’s talk through this problem before we solve it. We will enter guess values, as before, for both x and y. In cells B17
and B18 we will enter in Equations 1 and 2, respectively. Before we solve, we need to set an objective function to relate
the two equations with each other. In this case, we can just add the two equations together, and will set it as our
objective for it to equal zero. We will then be ready to solve. Our solutions should be x =0.857 and y =5.143 as can be
estimated from the graph.

Before we use the Solver, we need to input the pre-requisite data into the worksheet that includes the guess values,
the two equations, and the objective function that correlates the equations.

In cell B14, input a guess value of 1.

In cell B15, input a guess value of 5.

In cell B17, input the equation =2.5*B14-B15+3 and press Enter.

In cell B18, input the equation =-B14-B15+6 and press Enter.
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In cell B20, input the objective function =B17+B18.

Now that we have all the information entered into the worksheet, we can use the Solver to solve for x and y.

Click on Solver in the Data tab as before.

Click Reset All to start over.

Input the following into the forms:

Set Objective: $B$20
To: Value Of: 0

By Changing Variable Cells: $B$14:$B$15
Solving Method: Simplex LP

Click Solve.
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A dialogue box will prompt you to either keep or discard the solution. Click OK to keep it.

Solver found a solution for our objective function equal to zero (and may have found one different than above), but it
is still not quite what we want. Notice that our equations in cells B17 and B18 are not equal to zero. We can make one
simple addition in our Solver window to correct this problem.

Select Solver

In the Subject to the Constraints field, click Add.

We must set one of these equations equal to zero.

Input the following in the Add Constraint box:

Cell Reference: $B$17 or $B$18
Operator: =

Constraint: 0

Click OK.

Click Solve and then OK once again.
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We can now see that by adding one constraint, Solver found a solution all of our requirements: 
   Equation 1 = Equation 2 = Equation 1 + Equation 2 = 0

As seen in this example, you could say that Solver is not always accurate in solving sets of equations. In reality, Solver
is correct but you did not completely constrain the problem in the way you meant. Make sure to always double check
your work after a solution is reached (hence the graph).

Practical Nonlinear Example

In this last example, we will look at a practical application for Solver. In this case, we own a small business with 4
employees providing a computer repair service and charge our customers $30 per job. Each employee is paid a wage
shown below:

The Jobs column indicates how many jobs each employee completed during the month. The Earnings column is the
total earning of each worker, simply the Wage column multiplied by the Jobs column.

Firstly, set up the formulas and functions to complete the Total Jobs, Total Wages, Revenue, and Profit cells.

In cell C31, type the function =SUM(C26:C29) and press Enter.

In cell C33, type the function =SUM(D26:D29) and press Enter.

In cell C35, type the formula =C31*H27 and press Enter.

Calculate the profit by subtracting the wages from the revenue.

In cell C37, type the formula =C35–C33 and press Enter.

We now have a multitude of variables to change to try to optimize our business. We are going to determine the
optimal price to charge our customers by setting the following constraints:

Each employee completes at least 5 jobs per month

Minimum Total Profit of $700

No more than 30 total jobs every month

Select Solver in the Analyze panel of the Data tab.

Click Reset All.
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Cell Selection

Non-adjacent cells can be selected
together by holding the Control or
Command button on your
keyboard and making selections.
Here, cell H27 can be selected with
C26:C29 using the above method.

Input the following into the forms:

Set Objective: $C$37
To: Value Of: 700

By Changing Variable Cells: $C$26:$C$29,$H$27
Solving Method: GRG Nonlinear

Contraints:

$C$26:$C$29 = integer

$C$26:$C$29 >= 5
$C$31 <= 30

Click Solve followed by OK.

We added a few contraints to make sure our solution is valid and not nonsensical. The first contraint specifies that
the number of jobs has to be an integer, that is, we want the job number rounded off to the next whole number as one
cannot perform 3.45 jobs, for example.

3

4



All of our conditions have been met and we can see that we need to charge our customer $38.98 per job. Note that
often times multiple solutions are possible and that you may get different answers while running the same problem.
You can always add additional constraints until you get an answer that best fits your needs.

Analysis ToolPak
In addition to Solver, there are other Add-Ins we can use and one of the largest is the Analysis ToolPak. This Add-In
allows for financial, scientific and statistical data analysis. Switch to the worksheet named Aerobic Activity for this
section.

This file is an example of a hypothetical study of the connection between an individual’s BMI (body mass index) and
hours of aerobic activity per week. The given information in the table includes the individual’s gender, weight before
exercise and their current hours spent doing aerobic activity per week. For this example, we will calculate each
participant’s predicted body weight after performing aerobic activity on a weekly basis, and use this information to
calculate their new BMI.

BMI and Weight Loss Calculation
Before we move on, let us complete the table in this worksheet. This will also help review some functions in Excel. We
will now calculate each participant’s predicted weight given their hours of exercise per week. Their new predicted
weight can be calculated from the following formula: 
   New weight = old weight - (0.15* hours of aerobic activity), 
where 0.15 is weight loss constant found in cell K5.

In cell E3, type the equation for an individual's predicted weight: =D3-$K$5*C3 and press Enter.

Autofill the entire column with this formula by clicking and dragging from the bottom-right of the cell.
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Next, to calculate the BMI of each participant, we will use the following equation: 
   BMI = (Predicted weight)*0.454/(height*0.3)^2, 
where 0.4536 is the conversion factor from pounds to kilograms and 0.3048 is the conversion factor for feet to
meters. These constants can be found in cells K6 and K7.

In cell G3, type the following equation: =E3*$K$6/POWER((F3*$K$7),2) and press Enter.

Autofill the entire column with this formula by clicking and dragging from the bottom-right of the cell.

Now calculate the average BMI of all participants.

In cell K8, type =AVERAGE(E3:E32).
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Solver parameters

Here, we are minimizing average
BMI in cell K8 by constraining the
hours of aerobic activity in cells
C3:C32 to less than or equal to 7.

Optimizing Results with Solver
We can use Solver to put constraints on our data for a What-If Analysis.Note he current average BMI for all
participants in cell K8. Suppose that after reviewing health statistics, we want to minimize the average BMI by
changing the hours each participant works out a week. We can use Solver to minimize the average BMI by maximizing
the hours participants work out.

Before we minimize the average BMI, we would also like to ensure that no participant is completing more than 7
hours of aerobic activity per week.

Click on Solver under Analyze in the Data tab.

Input the following into the forms:

Set Objective: $K$8
To: Min

By Changing Variable Cells: $C$3:$C$32
Solving Method: GRG Nonlinear

Contraints: $C$3:$C$32 <= 7
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Click Solve followed by OK to retain the optimized values.

The average BMI should now be smaller tahn before as a result of all the hours of aerobic activity being maximized to
7 hours.

Descriptive Statistics

The first analysis we will perform on our data is calculating some general statistical information using Descriptive
Statistics fomr the Analysis ToolPak. We can get information such as the mean, median, mode, etc.

Select Data Analysis from the Analyze panel on the Data tab.

Select Descriptive Statistics and click OK.

In the Input Range form, enter $E$2:$G$32

Leave the Columns radio button check for the Grouped By option.

Enter "Descriptive-Stats" in the New Worksheet Ply form

Select the Summary statistics checkbox and click OK.

A table with the relevant statistical information will be displayed in the Descriptive-Stats worksheet. Below is the
table we should see, but formatted for ease of reading. We may format our table similarly.
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Histograms

Another valuable tool when looking at statistics is the histogram. Histograms are useful when looking for a visual
representation of frequency of data, in other word, in other words, the number of occurences of a specific value.
Switch to the Aerobic Activity worksheet for this exercise.

First we need to create a range for the data to be plotted on the histogram. We will call this the "Bin."

In cell J12, type Bin. This will be the label of our "bin" column.

In cell J13, enter 15.

In cell J14, enter 20.

Use Autofill to fill up a column of values from 15 to 50 in increments of 5.

Excel will now group data, for example, everything greater than 40 and less than or equal to 45 will be accounted for
in the 45 bar of the histogram. Let us go ahead and create the histogram now.

Select Data Analysis from the Analyze panel on the Data tab.

Select Histogram and click OK.

In the Input Range form, enter G2:G32.

In the Bin Range form, enter J12:J18.
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Check the Labels checkbox

Type "Histogram" in the New Worksheet Ply form under Output options to create the histogram in a new
worksheet with that name.

Check Chart Output to display a chart of the data and click OK.

The grouped data with along its corresponding frequencies and the histogram chart will be displayed in the
Histogram worksheet.

The Office support webpage, linked here has information on all the available Analysis ToolPak tools for your
reference.
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