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Introduction
Tableau is a data visualization software that creates aesthetically pleasing charts, graphs, and tables from complex data
sources. Today, we will be visualizing information about Madison's parks for a tourism brochure.
Before you begin, you will need to choose which version of Tableau you will be using: Tableau Public or Tableau Desktop.
Note that this manual will assume that the user is in Tableau Public, although the steps will be largely the same for either
version of Tableau. Differences between versions will be pointed out as needed.

Tableau Public is a free software that will allow you to quickly create visualizations and easily share them with large groups of people.
The main downside to Tableau Public is that you cannot save your work without putting it online. Thus, Tableau Public is not recommended for
visualizing confidential or valuable information.
Tableau Desktop will have more functionality than Public. While Tableau Public requires the user to import data from an Excel or text format, Tableau
Desktop allows data from a number of different sources such as SQL and Google Analytics. In addition, Tableau Desktop will be able to store work on
your computer rather than uploading it to the Internet.
Tableau Desktop can publish content to the Internet just like Tableau Public can. It can also create more polished, fully interactive Tableau files that can
be opened with either Tableau Desktop or a free program called Tableau Reader.

Full-time students at accredited universities can get a one-year trial of Tableau Desktop, but past that point it becomes very
expensive. If you are currently a student, take advantage of the trial period while you can!

Downloading Tableau Public
Tableau Public is completely free and quite simple to set up! If you already have Tableau on your computer, you may skip to
the next section.
1

First, go to https://public.tableau.com/s/download, put any valid email address into the textbox, and click
"Download the App."

A setup file will be saved to your browser's Downloads folder.

2

Open this file and install Tableau according to the steps of the setup wizard. Once the process is complete, Tableau
should open automatically on your computer! If not, you can find it in your computer's Applications or Programs
folder.

Connecting to Data
Tableau is capable of creating databases, but it is much easier and more efficient to connect an already-created database to
Tableau.

Exercise: Connecting a Text File
1

If you haven't already, open up Tableau.

In the Connect panel on the left, there are several options of where to get data. We will use the Text File option.
2

Click on "Text File," the second option under Connect > To a file.

3

Browse to parksdata.csv in the Class Files folder. This is a file with information
on Madison’s parks taken from data.cityofmadison.com.
Tableau will take us to the Data Source screen. Here, we can survey our data
in a spreadsheet format and make sure the Tableau is correctly interpreting
our data.

What's a CSV?
A .csv is a text file containing
information separated into
columns by comma characters. You
can use Excel to create a .csv file
out of an Excel spreadsheet by
clicking File > Export > Change File
Type > CSV File > Save.

We have successfully connected our parks data to Tableau. Using the scroll bar on the bottom of our data, take notice of all
the columns, or fields, in our spreadsheet. Tableau automatically sorts each field into one of six different categories:

Text values (strings)
Date values
Date and Time values
Numerical values
Boolean values (true/false)
Geographic values (used with maps)
Notice that Tableau has made guesses as to what kind of data each field contains. If you believe that Tableau has
miscategorized a field, you can click on the icon for that field and change it to a different data type.
From the data in our .csv, we will use Tableau to create three Worksheets, or visualizations, and then we will compile them
into a Dashboard.

Creating Visualizations with Worksheets
Tableau has automatically created our first Worksheet. Click on the the Sheet 1 tab at the bottom of the
screen to access it.
Tableau will then take us to a new screen:

Notice that every field in our data is now separated into two categories: dimensions
and measures.

Dimensions denote qualitative, categorical distinctions
between a set of possible values. They answer questions like,
“What kind of park is X?”
Measures refer to continuous spectrums of measurement.
They answer questions like, “How large is Park X?”.

Worksheet 1: Bar Chart

Extra Fields
Note that some dimensions and
measures are represented in italics.
These fields were not originally in
our data -- Tableau has created
them for us automatically!

Our Type field (in the Dimensions section) has seven different values, and every park record has one of these seven values in
its Type field. For our first visualization, we’ll look at how many parks there are of each Type: in other words, we will create a
graph where each column on the x-axis corresponds to a type of park and the y-axis denotes how many records in our
dataset correspond to each type.

Creating a Visualization
1

Find the dimension called Type from the Data panel on the left. You may have to scroll down to find it. Click and drag
Type to the Columns box on the top of the Worksheet interface, then release the mouse.
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Similarly, click and drag the Measure called Number of Records to the Rows box.

Tableau will make several automatic changes to the workspace. Most notably, a bar graph will appear!

Now that we have successfully created a visualization, we can work on its aesthetics to make it more informative and
readable.

The Marks Panel
First, let's assign a distinct color to each park type by using the Marks panel. The Marks panel
converts differences in data values into differences in color, size, or labeling.
1

Drag the Type dimension (straight from the Data panel again, not from the Columns box!) to
the icon that says Color in the Marks panel. A "Type" pill will appear in the bottom of the
Marks panel, and Tableau will update the chart to show every different park type in a unique
color!

About these colors
This will become more clear later
on, but the colors assigned to each
park type will actually remain the
same for all of the visualizations in
our Tableau project! If you would
like to edit these colors, click on
the drop-down arrow on the topright corner of the Type panel
(underneath the Marks panel).

More Chart Editing
We can organize our chart’s spatial makeup with three special buttons on the Toolbar, on the top of your screen.

The first button will swap the axes for your graph, and the second two will arrange the columns in either ascending or
descending order.
1

Click the first button to change our vertical bar chart into a horizontal bar chart.
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Click the third button to arrange our bars in descending order.
If you like, you can also move each bar’s position by clicking and dragging their labels up or down in the new Type
panel.

Our bar chart is finished! Before we go on to the next worksheet, let’s name our current visualization.
3

Double-click on the “Sheet 1” tab at the bottom of the window and change the name to Bar.

Worksheet 2: Area Visualization
For some visualizations, you won’t need to use axes at all! Let’s create a free-form visualization where we can see the relative
average size of each type of park.
There are three steps to this visualization:

First, we will create a visual mark for each type of park.
Second, we will label these visual marks.
Third, we will adjust the size of each mark to represent the size of the average park in that
category.
All of this will be accomplished with the Marks panel in Tableau!
1

Click the New Worksheet button at the bottom of the Tableau interface. A new tab will appear next to our
Bar tab.

2

Drag Type from the Data panel to the Color icon in the Marks panel.

3

Drag Type from the Data panel again -- but this time, drag it to the Label icon in the Marks panel.

4

Drag Acreage from the Measures section of the Data panel to the Size icon in the Marks panel.

Tableau has automatically chosen a visualization that helps us see relative sizes between
types! However, there is one problem: as you can see in the Marks panel, Tableau is
showing us the SUM of the acreage of each type -- essentially, adding together the area of every park represented by
that type. We would like it to show the AVERAGE area of each park type instead.
5

Click on the dropdown arrow on the right side of the SUM(Acreage) pill in the Marks panel.
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In the dropdown menu, hover over "Measure (Sum)" and change the measure to Average.

This has made a few important changes to the hierarchy of our visualization.

These rectangles are nice, but it's difficult for the human eye to judge size differences between rectangles of
different proportions. As a final change to the current worksheet, let's change the rectangles into circles.
7

In the Marks panel, click the dropdown box that currently reads “Automatic” and change it to “Circle.” The
visualization will change dramatically.

8

To finish this worksheet, change its name by double-clicking on the “Sheet 2” tab and renaming it to “Average Area.”

Worksheet 3: Map
Our data has fields formatted as Latitude and Longitude. By creating a scatter plot of these fields' values and overlaying
them on a map of Madison, Tableau can create a geographical visualization of our data!
1

Click the Create New Worksheet button again to open a new worksheet.

2

Simply double-click on the Latitude and Longitude fields in the Data Panel. Tableau will automatically update the
background to be a map! You can navigate around this map by using the buttons on the upper left or clicking and
dragging with your mouse to pan.

The only problem is that there is only one data point -- we are only seeing the
average latitude and the average longitude for all of our data points. We will
remedy this by creating a separate mark for each data point.
3

Drag the field named Id from the Data panel to the Marks panel, but not to any
of the icons -- just drag it to the white space below “Detail” and “Tooltip.” The
single data point will explode into many, each representing a single park.

Two quick additions to the Marks panel will make our map much more informative.
4

As before, drag Type to the Color icon.

5

Also as before, drag Acreage to the Size icon.

Why Id?
In our dataset, every park record
has a distinct value for its Id field.
Thus, the Id value will be different
for every single park, and we can
use it to create a discrete mark for
every park in our dataset.

These changes have made our map very interesting to look at; however, the default sizes are not quite big enough to
be clearly visible.
6

Click on the dropdown arrow on the new SUM(Acreage) panel that has just appeared below the Marks panel, and
click Edit Sizes. The Edit Sizes window will appear.
1

Drag the right-hand slider under “Mark Size Range:” slightly to the right. This will intensify the relationship
between a park’s Acreage value and its size on the map.

2

Check “Start value for range” and set the value to -20. This will increase the size of all data points.

You can play with these settings until you find a configuration you like, using the Apply button to see your
changes.
3

When you are finished, click OK.

We are finished with this visualization, so let's give it a name!
7

Double-click on “Sheet 3” and rename it “Map.”

Combining Worksheets with a Dashboard
We are now ready to create a Dashboard! A Dashboard is an interactive space to put visualizations together and see how
they can interact with one another.
1

Click the New Dashboard button, to the right of the New Worksheet button.

Our interface has changed quite a bit! Now, where there were Dimensions and Measures, we can see the three other
worksheets in our Tableau project. You can drag a visualization to the workspace just like we did with data fields
previously.
2

Drag the three worksheets, one by one, to the Dashboard.
This part of creating dashboards is quite touchy -- it may take a bit of getting used to. Take some time to figure out
how Tableau updates the layout for every change you make in the organization of your worksheet elements.

We can further customize how our dashboard looks! Every dashboard element, when selected, will have a tiny
dropdown arrow which can be clicked to reveal more options. Try taking the titles off of your worksheet elements.
3

Click the dropdown arrow for one of your visualizations and uncheck “Title,” then do the same for your other two
elements.
You can also add captions, edit the axes, and perform many other customizations to your visualizations.Once you feel
you are finished, you’re ready to publish your workbook!

Publishing
Publishing with Tableau Desktop
1

Click File > Save As to save your file as a Tableau package, or File > Export to make it into a .pdf or picture.

Publishing with Tableau Public
1

Click File > Save to Tableau Public As.
If you aren’t logged in, a window will pop up. Enter your Tableau email address and password -- if you don’t have one,
you can create one with the link at the bottom of the window.
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In a new window that pops up, enter the name of your workbook and click Save.
You will need a working Internet connection to save a workbook to Tableau Public. From there, your Tableau Public
account will function as a “home base” for your Tableau workbooks -- you can save, load, edit, and distribute your
work online.

